Help Center
< Back

Analyse von eSense Daten (CSV)

Sie können die Daten aus der eSense App exportieren und dann mit anderen Programmen (wie Microsoft Excel™ oder Google Tabellen™ ) weiter auswerten. In dieser Anleitung zeigen wir Ihnen alle Schritte, vom Exportieren aus der eSense App bis zum importieren und auswerten in Microsoft Excel™ und Google Tabellen™.

Für den eSense Pulse haben wir auch einen ergänzenden Artikel zur Kubios HRV Software.

Die in dieser Anleitung gezeigten Beispiele sind zum größten Teil auf den eSense Skin Response bezogen. Prinzipiell lassen sich Daten von dem eSense Temperature, eSense Pulse, eSense Respiration oder eSense Muscle aber auf dieselbe Art und Weise verarbeiten.

Exportieren der Messwerte aus der Mindfield eSense App

Die App beinhaltet ein Archiv, in dem Sie Ihre Aufzeichnungen betrachten, vergleichen und exportieren können.

Daten exportieren

Bei Klick auf das Export-Symbol oben rechts oder auf den Button „Export Als CSV Datei“ unten können Sie die Aufzeichnungen im .csv-Format mit allen gängigen Apps exportieren (bspw. versenden über den Messenger™, WhatsApp™, Email etc.) oder einfach auf Ihrem Telefon oder in Ihrer Cloud (bspw. Google Drive™ oder Dropbox™) speichern.

Die Daten werden als .csv-Datei (comma seperated values) exportiert. Dieses Dateiformat können Sie z.B. mit Microsoft Excel™ oder Open Office Calc™ (kostenlose Alternative zu Excel) öffnen.

Falls Sie gerne mit Google arbeiten, können auch Google Tabellen™ (Google Sheets™) eine Alternative zu Excel für Sie sein. Damit können Sie Ihre exportierten .csv Dateien ebenfalls öffnen, visualisieren und über die Cloud einfach von mehreren Geräten zugreifen. Google Tabellen™ hat dabei ähnliche Funktionen wie Excel und auch eine sehr ähnliche Bedienung.

Allgemeiner Hinweis

Die exportierten Dateien sind immer CSV-Dateien. CSV steht hier für „Comma seperated values“. Dies bedeutet, dass die Werte in der Datei mit einem Komma (,) getrennt sind.

Diese CSV-Dateien können mit Programmen wie Microsoft Excel™ oder Google Tabellen™ geöffnet und bearbeitetet werden. Auch ist ein Import und die Bearbeitung mit häufig verwendeten Programmiersprachen oder Frameworks wie beispielsweise SPSS™, Matlab™, R™, Python™, Numpy™ oder Tensorflow™ möglich.

Diese Anleitung bezieht sich auf Microsoft Excel™ und Google Tabellen™ (Google Sheets™). Wir empfehlen gerade auch Einsteigern eher Google Tabellen™ als Microsoft Excel™ zu verwenden, da es etwas einfacher zu bedienen ist und es oft mit unseren Messungen besser funktioniert (bsw. Werden die Sekunden nicht automatisch zu Datums vormattiert, siehe im Abschnitt zu Excel). Google Tabellen™ ist auch etwas besser beim schnellen automatischen Erstellen von Diagrammen. Die Nutzung von Excel macht eher Sinn, wenn Sie bereits besser mit Excel vertraut sind.

Sie können Google Tabellen™ hier finden: https://www.google.de/intl/de/sheets/about

Ihre Einstellungen von Excel™ und Google Tabellen™ sind hierbei entscheidend. Die eSense App passt die Messwerte an die verwendete Sprache an. In Englisch werden die Zahlen in der Regel mit einem Punkt getrennt. So wird aus 1,5 in der deutschen Version eine 1.5 in der englischen Version. Wenn Sie also die CSV-Datei mit Excel™ oder Google Tabellen™ öffnen und die Zahlen keinen Sinn ergeben sollten, liegt es meist an unterschiedlich eingestellten Sprachen in der eSense App und Excel™ oder Tabellen™.

Grundsätzlich gilt daher: Wenn Sie Excel™ oder Tabellen™ in Deutsch verwenden, sollten Sie auch die eSense App in Deutsch verwenden. Wenn Sie Excel™ oder Tabellen™ in Englisch verwenden, sollten Sie auch die eSense App in Englisch verwenden. Dies erspart Ihnen die jeweils ersten beiden Schritte (Dezimaltrennzeichen ersetzen und Werte auf Spalten aufteilen), und Sie können direkt mit Schritt 3 (Hautleitwert gegen Zeitpunkt auftragen) beginnen.

Microsoft Excel™

1. Dezimaltrennzeichen ersetzen (nur nötig, falls Sie unterschiedliche Sprach-Einstellungen in Excel™ und der eSense App haben)

  1. Drücken Sie dazu Strg und H (suchen und ersetzen).
  2. Ersetzen Sie alle Kommata (oder Kommas) „ , “ durch Semikolon „ ; “ (Ersetzen des Spaltentrennzeichens)
  3. Ersetzen Sie alle Punkte „ . “ durch Kommas „ , “  (Ersetzen des Dezimaltrennzeichens)
  4. (Alternativ können Sie auch das von Excel™ standardmäßig verwendete Dezimaltrennzeichen ändern: Klicken Sie auf Datei–Optionen–Erweitert. Deaktivieren Sie dort den Punkt „Trennzeichen vom Betriebssystem übernehmen“ und wählen Sie Punkt als Dezimaltrennzeichen und Komma als Tausendertrennzeichen aus.)
Dezimaltrennzeichen ersetzen

2. Werte auf Spalten aufteilen (nur nötig, falls Sie unterschiedliche Sprach-Einstellungen in Excel™ und der eSense App haben)

Noch befinden sich die Werte für Zeitpunkt und Messwert beide in der ersten Spalte, mit Komma oder Semikolon voneinander getrennt. Sie müssen sie auf zwei Spalten aufteilen.

  1. Markieren Sie die gesamte erste Spalte A
  2. Klicken sie im Menü „Daten“ auf die Funktion „Text in Spalten“
  3. Wählen Sie Dateityp „getrennt“ aus und klicken Sie auf weiter.
  4. Wählen sie das Trennzeichen Komma (,) oder Semikolon (;) je nachdem welches Zeichen die Werte trennt
  5. Klicken Sie auf „weiter“, Dateiformat „Standard“, und „Fertig stellen“.
Werte auf Spalten aufteilen

3. Sekunden richtig formatieren (optional)

Excel formatiert die Sekunden in der ersten Spalte oft automatisch zu einem Datum. Leider gibt es keine Möglichkeit dies zu deaktivieren, dies ist von Excel so voreingestellt. Es gibt aber ein paar Wege um dies zu lösen: https://support.microsoft.com/de-de/office/verhindern-der-automatischen-umwandlung-von-zahlen-in-datumswerte-452bd2db-cc96-47d1-81e4-72cec11c4ed8#:~:text=Wenn%20Sie%20nur%20ein%20paar,(Siehe%20Hinweise)

4. Hautleitwert gegen Zeitpunkt auftragen.

  1. Markieren Sie beide Spalten (Sekunden und Mikrosiemens/Celsius/Fahrenheit) vollständig (Tipp: klicken Sie mit der Maus in die Spalte, in der „Messwerte“ steht. Dann drücken Sie die STRG- und Shift-Taste gleichzeitig, halten diese gedrückt und drücken dann die Pfeiltaste nach links und nach unten. Mit dieser Abkürzung können Sie schnell beide Spalten auch bei tausenden von Messwerten markieren).
  2. Wählen Sie im Menü „Einfügen“ die Diagrammart „Punkt“ und darin den Diagrammtyp „Punkte mit interpolierten Linien“. Sie erhalten ein Diagramm mit dem Zeitpunkt in Sekunden in der horizontalen Achse. Alternativ können Sie auch „Linie“ auswählen.
  3. Hinweis: Wenn Sie die neueste Version von Excel™ benutzen, können Sie auch „Empfohlene Graphen“ ausprobieren. Oft erkennt Excel™ bereits automatisch den passenden Graphen.
Diagramm erstellen (Punkte mit interpolierten Linien und Datenpunkten)
Das fertige Diagramm (Typ Linie) einer Messung mit dem eSense Skin Response
Das fertige Diagramm (Typ Linie) einer Messung mit dem eSense Pulse

5. Hautleitwert gegen Markierungen eintragen

  1. Erstellen Sie zuerst das Diagramm vom vorherigen Schritt 3 (Hautleitwert gegen Zeit auftragen).
  2. Im Menu unter „Diagramtools“ -> „Entwurf“ wählen Sie „Daten auswählen“. Es erscheint dann eine neue Maske.
  3. Unter „Legendeneinträge (Reihen)“, wählen Sie „Hinzufügen“.
  4. Geben Sie einen Reihennamen an (z.B. „Markierungen“) und wählen Sie für die Reihenwerte Ihre Markierungen aus (in der Spalte F).
  5. Wählen Sie aus dem Menu „Diagrammelement hinzufügen“ -> „Datenbeschriftungen“ -> „Weitere Datenbeschriftungsoptionen“.
  6. Ein Menu wird rechts aufgehen. Dort können Sie unter „Beschriftungsoptionen“ -> „Werte aus Zellen“ auswählen (und gegebenenfalls „Werte“ deaktivieren). Es öffnet sich wieder eine Maske, und Sie müssen nochmals Ihre Markierungen aus der Spalte D markieren.
  7. Wenn Sie ebenfalls Linien zu den Stellen in den Graphen haben wollen, müssen Sie „Diagrammelement hinzufügen“ -> „Spannweitenlinien“ auswählen.
  8. Sie können nun noch Farben oder die Schriften anpassen.
Das fertige Diagramm mit Markierungen einer Messung mit dem eSense Skin Response

6. Hautleitwert gegen SCR eintragen (nur für eSense Skin Response)

  1. Erstellen Sie zuerst das Diagramm vom vorherigen Schritt 3 (Hautleitwert gegen Zeit auftragen).
  2. Im Menu unter „Diagramtools“ -> „Entwurf“ wählen Sie „Daten auswählen“. Es erscheint dann eine neue Maske.
  3. Unter „Legendeneinträge (Reihen)“, wählen Sie „Hinzufügen“.
  4. Geben Sie einen Reihennamen an (z.B. „SCR“) und wählen Sie für die Reihenwerte Ihre SRC/Min aus (in der Spalte F).
  5. Im Menu unter „Diagramtools“ -> „Entwurf“ wählen Sie „Diagrammtyp ändern“. Es erscheint dann eine neue Maske. Wählen Sie im Tab „Alle Diagramme“ -> „Verbund“ -> „Benutzerdefinierte Kombination“. Wählen Sie für die SCR im Dropdown-Menü „Gruppierte Säulen“ aus und stellen Sie sicher, dass das Häkchen bei Sekundärachse gesetzt ist (siehe auch folgenden Screenshot).
SCR-Serie als gruppierte Säulen hinzufügen
Ein weiteres Kombo-Diagramm mit Skin Response und SCR

Google Drive (Google Sheets™, empfohlen)

Auch hier kann es, ähnlich wie in Excel™, Komplikationen mit den Trennzeichen geben. Die exportieren Dateien sind immer CSV-Dateien. CSV steht hier für „Comma seperated values“. Dies bedeutet, dass die Werte in der Datei mit einem Komma (,) getrennt sind.

Oft versucht Google auch die Daten automatisch zu formatieren. Dann kann es unter anderem passieren, dass die Messwerte als Datum interpretiert werden. Um dies zu verhindern, sollten Sie im ersten Schritt sicherstellen, dass unter „Format“ -> „Zahl“ -> „Zahl“ ausgewählt ist.

1. Dezimaltrennzeichen ersetzen (nur nötig, falls Sie unterschiedliche Sprach-Einstellungen in Google Tabellen™ und der eSense App haben)

  1. Drücken Sie dazu Strg und H (suchen und ersetzen).
  2. Ersetzen Sie alle Kommas „ , “ durch Semikolon „ ; “ (Ersetzen des Spaltentrennzeichens)
  3. Ersetzen Sie alle Punkte „ . “ durch Kommas „ , “  (Ersetzen des Dezimaltrennzeichens)
Dezimaltrennzeichen ersetzen

2. Werte auf Spalten aufteilen (nur nötig, falls Sie unterschiedliche Sprach-Einstellungen in Google Tabellen™ und der eSense App haben)

Je nach ihren Spracheinstellungen befinden sich die Werte für Zeitpunkt und Messwert beide in der ersten Spalte, mit Komma oder Semikolon voneinander getrennt. Sie müssen sie auf zwei Spalten aufteilen.

  1. Markieren Sie die gesamte erste Spalte A.
  2. Klicken sie im Menü „Daten“ auf die Funktion „Text in Spalten aufteilen“.
  3. Wählen Sie Dateityp „getrennt“ aus und klicken Sie auf weiter.
  4. Wählen sie das Trennzeichen Komma (,) oder Semikolon (;), je nachdem welches Zeichen die Werte trennt.

3. Hautleitwert gegen Zeitpunkt auftragen.

  1. Markieren Sie beide Spalten. Jeweils die erste Spalte mit den Sekunden und eine Weitere Spalte mit den Messwert je nach eSense Sensor (Mikrosiemens beim Skin Response, Celsius/Fahrenheit beim Temperature, Herzrate oder RR-Interval oder HRV-Amplitude beim Pulse, RR oder Atemzüge pro Minute beim Respiration) vollständig
    (Tipp: klicken Sie mit der Maus in die Spalte wo „Messwerte“ steht. Dann drücken Sie die STRG- und Shift-Taste gleichzeitig, halten diese gedrückt und drücken dann die Pfeiltaste nach links und nach unten. Mit dieser Abkürzung können Sie schnell beide Spalten auch bei tausenden von Messwerten markieren).
  2. Wählen Sie im Menü „Einfügen“ -> „Diagramm“. Hinweis: Google Tabellen™ versucht oft automatisch das richtige Diagramm zu erstellen. Manchmal funktioniert dies auch gut, manchmal aber auch nicht. Falls das Diagramm keinen Sinn ergeben sollte, fahren Sie einfach mit den nächsten Schritten fort.
  3. Klicken Sie auf das Diagramm. Eine Dialogbox sollte am rechten Rand aufgehen. Wählen Sie als Diagrammtyp „Geglättetes Liniendiagramm“. Für „X-Achse“, stellen Sie sicher, dass Sekunden ausgewählt sind. Für die „Reihe“, stellen Sie sicher, dass Ihre Messwerte ausgewählt sind. Sehen Sie dazu auch den folgenden Screenshot.

4. Hautleitwert gegen Markierungen eintragen

  1. Löschen Sie die Spalte C mit dem Zeitstempel.
  2. Markieren Sie die Spalte mit Ihren Messwerten und die Spalte mit Ihren Markierungen gleichzeitig (wie im folgenden Screenshot gezeigt).
  3. Wählen Sie im Menü „Einfügen“ -> „Diagramm“. Hinweis: Google Tabellen™ versucht oft automatisch das richtige Diagramm zu erstellen. Manchmal funktioniert dies auch gut, manchmal aber auch nicht. Falls das Diagramm keinen Sinn ergeben sollte, fahren Sie einfach mit den nächsten Schritten fort.
  4. Klicken Sie auf das Diagramm. Eine Dialogbox sollte am rechten Rand aufgehen. Wählen Sie als Diagrammtyp „Geglättetes Liniendiagramm“. Für die „Reihe“ stellen Sie sicher, dass Ihre Messwerte ausgewählt sind. Als „Beschriftung“ sollten Ihre Markierungen ausgewählt sein. Sehen Sie dazu auch den folgenden Screenshot:
Ein weiteres Diagramm welches die SCR und Markierungen zeigt

Die mit Google Tabellen erstellten Diagramme können auch per iFrame eingebettet werden, wie in diesem Beispiel gezeigt:

Back Kompatible Android und iOS Geräte
More eSense Daten zu einem PC/Mac/Browser streamen (eSense Web App, OSC)
Fragen

Stelle eine Frage

Ihre E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert